Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意:给你一些集合,不同集合中的元素可能有重复,其中0号是病人,凡是解除过病人的人都会变成病人,问最后多少人被感染了。
题解:简单的并查集查询即可,不过一开始我直接在加入时以0为根节点,但实际上并不用多此一举,只要在查询直接查询是否与同一根节点即可。
代码:

#include<algorithm>
#include <iostream>
#include  <cstdlib>
#include  <cstring>
#include  <cassert>
#include   <cstdio>
#include   <vector>
#include   <string>
#include    <cmath>
#include    <queue>
#include    <stack>
#include      <set>
#include      <map>
using namespace std;
#define P(a,b,c) make_pair(a,make_pair(b,c))
#define rep(i,a,n) for (int i=a;i<=n;i++)
#define per(i,a,n) for (int i=n;i>=a;i--)
#define CLR(vis) memset(vis,0,sizeof(vis))
#define MST(vis,pos) memset(vis,pos,sizeof(vis))
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
#define SZ(x) ((int)(x).size())
typedef pair<int,pair<int,int> >pii;
typedef long long ll;
const ll mod = 1000000007;
ll gcd(ll a, ll b) { return b ? gcd(b, a%b) : a; }

const int maxn = 3e4+5;

int pre[maxn];
int rank[maxn];
int find(int x){
	return pre[x]==x?x:pre[x]=find(pre[x]);
}

void unionn(int a,int b){
	a = find(a);
	b = find(b);
	if(a==b)return;
//	if(a==0){
//		pre[b] = a;
//	}else if(b==0) pre[a]=b;
	else{
		if(rank[a]<rank[b]) pre[a]=b;
		else {
			pre[b] = a;
			if(rank[a] == rank[b]) rank[a]++;
		} 
	}
	
}
void init(int n){
	rep(i,0,n-1){
		rank[i]=1;
		pre[i]=i;
	}
}
int main(){
	int n,m;
	while(scanf("%d%d", &n,&m)==2&&(m!=0||n!=0)){
		init(n);
		int t;
		while(m--){
			scanf("%d", &t);
			int last,now;
			scanf("%d", &last);
			rep(i,2,t){
				scanf("%d", &now);
				unionn(last,now);
				last = now;
			}
		}
		int cnt=0;
		rep(i,0,n-1){
			if(find(i)==find(0))cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注