TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

InputLine 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
OutputA single line with a integer denotes how many answers are wrong.Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

题意:给你一个区间,这个区间上的整数位都有一个对应值,m次询问,输出有多少次与前面询问冲突的次数。
题解:因为是第一次接触这样的问题,不明白应该怎么合理地构造关系。
将一边(比如左边)当作根节点,当给出一个区间时,查询上下限是否是同一根节点,是则判断,不是则通过val[fy]=val[x]+w-val[y]这个式子来确定val[fy]的值,因为最后判断时判断的是差值,所以只要往一个方向(比如左)进行并集即可,不用在意大小关系以及val的正负关系。
u=u-1以保证区间连接,就酱
代码:

#include<algorithm>
#include <iostream>
#include  <cstdlib>
#include  <cstring>
#include  <cassert>
#include   <cstdio>
#include   <vector>
#include   <string>
#include    <cmath>
#include    <queue>
#include    <stack>
#include      <set>
#include      <map>
using namespace std;
#define P(a,b,c) make_pair(a,make_pair(b,c))
#define rep(i,a,n) for (int i=a;i<=n;i++)
#define per(i,a,n) for (int i=n;i>=a;i--)
#define CLR(vis) memset(vis,0,sizeof(vis))
#define MST(vis,pos) memset(vis,pos,sizeof(vis))
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
#define SZ(x) ((int)(x).size())
typedef pair<int,pair<int,int> >pii;
typedef long long ll;
const ll mod = 1000000007;
ll gcd(ll a, ll b) { return b ? gcd(b, a%b) : a; }

const int maxn = 2e5+5;
int pre[maxn],val[maxn];
int n,m;
int u,v,w,ans;
int find(int x){
	if(pre[x]==x)return x;
	int t=find(pre[x]);
	val[x]+=val[pre[x]];
	return pre[x]=t;
}
void init(int x){
	rep(i,0,x){
		pre[i]=i;
		val[i]=0;
		ans=0;
	} 
}
int main(){
	while(scanf("%d%d", &n,&m)==2){
		init(n);
		while(m--){
			scanf("%d%d%d", &u,&v,&w);
			u--;
			int fu=find(u),fv=find(v);
			if(fu!=fv){
				pre[fv]=fu;
				val[fv]=val[u]+w-val[v];
			}else{
				if(val[v]-val[u]!=w)ans++;
			}
		}
		printf("%d\n",ans);
		rep(i,1,n){
			cout<<val[i]<<" ";
		}
		cout<<endl;
	}
	return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注